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1. Introduction 

A PSCAD model of the region covered by grid zone 14 was developed for asset owners to conduct 
their own Electromagnetic Transient (EMT) connection studies in this region as per Connection Study 
Requirements for New Generating Assets (GL-EA-0953)1. The model contains detailed 
representations for grid zone 14, while the rest of the South Island grid network is represented by 
equivalent voltage sources and a simplified network. The model contains synchronous generator 
models along with their respective automatic voltage regulators (AVR) and passive reactive power 
compensation devices. 

The EMT network model components were created using E-TRAN software developed by Electranix 
Corporation2. The power-flow solution and network equivalent were created using DigSILENT 
PowerFactory. This document provides guidance for loading the network model into PSCAD, along 
with brief descriptions of the models.   

 

  

 

1 Connecting generation | Transpower 
2 E-TRAN Runtime library for PSCAD | Electranix Corporation 

https://www.transpower.co.nz/system-operator/information-industry/asset-owner-requirements/connecting-generation
https://www.electranix.com/software/e-tran-runtime-library-for-pscad/
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2. Files Provided by the System Operator  

The system operator provides the asset owner with the GZ_14_EMT_model .zip package containing 
the files shown in Figure 1. Table 1 includes descriptions of the files provided in the .zip package.  

 

 

Figure 1: Files provided in the .zip file. 

 

Table 1: Description of the files provided. 

File name Description 

dynamics.dyr Dynamic record file for generator, AVR and power system stabiliser (PSS) 

models. This file should be placed in the same folder as the EMT_14.pscx 

case. 

EMT_14.pscx  A single simulation file containing South Island grid zone 14 in detail. The 

model has boundaries at TWZ 220 kV and NSY 220 kV buses. 

ETRAN.pslx The runtime library developed by Electranix to be used with E-TRAN-

converted PSCAD files. The latest version of this library is freely available 

on the Electranix’ website3. 

ETRAN_IF12.lib The encrypted source code file for E-TRAN runtime library. This should 

be loaded as a resource file in the ETRAN.pslx library. 

 

3 E-TRAN Runtime library for PSCAD | Electranix Corporation 

https://www.electranix.com/software/e-tran-runtime-library-for-pscad/
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File name Description 

loads.csv 

(loads_summer_peak.csv, 

loads_summer_trough.csv, 

loads_winter_peak.csv) 

A .csv file detailing the loads within the network model. The data is 

obtained from the PowerFactory power-flow solution. Three load value 

files are provided for summer peak, summer trough and winter peak load 

conditions respectively. 

synchronous_machines.csv 

(synchronous_machines_summ

er_peak.csv, 

synchronous_machines_summe

r_trough.csv, 

synchronous_machines_winter

_peak.csv) 

A .csv file containing details of the synchronous machines within the 

network model. The data is obtained from the PowerFactory power-flow 

solution. Three generation dispatch files are provided for summer peak, 

summer trough and winter peak load conditions respectively. 

update_loads.py A python file used to update the load values provided by the loads.csv 

file. 

update_syncmachines.py A python file used to update the initial conditions of synchronous 

machines provided by the synchronous_machines.csv file. 

WP_GZ14.pswx This is a PSCAD workspace file which should load all necessary files into 

the PSCAD workspace to run the PSCAD case. 
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3. Setting up the Study Case 

The package is created using PSCAD V5.0.2 with Intel Fortran Classic 2021.12.0 compiler and Visual 
Studio 2022 installed.  Loading the package into older PSCAD versions and/or with an older Intel 
Fortran compiler and Visual studio version may cause the study case to fail. This section explains the 
steps that are required to load the study case.   

3.1 Loading the Case File and General Setup 

Once the provided .zip file is extracted, the user can open the WP_GZ14.pswx workspace file. This 
should load all necessary files and resources into the PSCAD environment. If the workspace fails to 
load correctly, the user can follow the sequence to load all the files manually. 

Use the File -> Open command from PSCAD to load both files below.   

1. ETRAN.pslx 
2. EMT_14.pscx 

Once these two files are loaded, expand the ETRAN.pslx library by clicking the + sign beside the file 
name in the workspace. Right-click on the Resources subfolder and navigate to the Add -> Binary 
(*.o, *.obj, *.lib) submenu.   

 

Figure 2: Adding .lib files to the project 

Then add the ETRAN_IF12.lib file as shown Figure 3.  

 

Figure 3: All the .lib files loaded in correct order. 

The following figure shows a snapshot of the PSCAD workspace after the workspace WP_GZ14.pswx 
is correctly loaded. 
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Figure 4: Screenshot of the correctly loaded PSCAD workspace and canvas. 

 

3.2 Case File Arrangement 

The network model is available within the GZ14 Network Model subpage in the canvas. Figure 5 
shows the layout of the network model. 

 

Figure 5. Layout of the network model. 
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3.3 Setting Up the Compiler 

An Intel® Fortran Compiler is required to run the simulation case. The simulation cases were 
developed using Intel® Fortran Compiler Classic 2021.12.0 compiler. The user must make sure a 
correct version of Intel Fortran compiler is installed on the computer4. The compiler can be selected 
by navigating to File -> Application Options -> Dependencies and selecting the correct Fortran 
compiler.  Figure 6 shows the window to configure the Fortran compiler. 

 

 

Figure 6: Setting up the compiler 

 

3.4 Setting Up the Project Simulation Time Step 

Setting up the correct simulation time step is crucial for accurate results. It is essential to run the 
simulation at a time step (solution time step) at 20 µs or below due to the modelling requirements. 
Users can use a slightly larger channel plot step to reduce the memory usage from the simulation. In 
this configuration, a 100 µs channel plot step is recommended. All these parameters can be changed 
in the Project Settings by right-clicking anywhere on the canvas as shown in Figure 7. 

 

4 Compatibility of compilers and Visual studio versions with PSCAD versions can be found at 
https://www.pscad.com/knowledge-base/article/102  

https://www.pscad.com/knowledge-base/article/102
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Figure 7: Setting up the solution time step.  
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4. Simulation Case Details 

The simulation case was developed based on the EMI PowerFactory study case for 202311, available 
on the Electricity Authority’s website5. The summer 2024 variation has been considered to obtain 
the minimum strength in the system.  

Users may replicate the power flow conditions by creating equivalents for other load condition 
variations or by updating the case using the latest version of the EMI study. For further assistance, 
please contact the system operator. 

 

4.1 Network Equivalents 

The network model contains network components associated with grid zone 14. The rest of the 
network is represented by equivalent voltage sources and a reduced network model to simplify the 
EMT simulation.  

The slack generator was set to Manapouri G1 with voltage angle of Manapouri 220 kV bus to be at 
0°. The network was reduced in PowerFactory based on the following selected boundary of the EMI 
PowerFactory case.  

 

 

Figure 8: EMI PowerFactory boundary for reducing rest of the South Island power grid. 

 

Once the network boundary is created in PowerFactory (named Boundary-GZ14 in this example), 
part of the network exterior to the boundary can be reduced via CALCULATION -> Additional 
Functions -> Network Reduction in PowerFactory. This will open the Network Reduction window. 
In this window, parameters should be set as follows to create an Extended Ward Reduction. Leave 
other settings as default. Once the settings are configured, press Execute6. 

 

5 Electricity Authority - EMI (market statistics and tools) (ea.govt.nz) 
6 Additional information regarding Network Reduction is available at PowerFactory user manual. 

https://www.emi.ea.govt.nz/Wholesale/Datasets/Transmission/PowerSystemAnalysis/PowerFactoryCaseFiles
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Figure 9: Network Reduction window: Basic Options. 

 

 

Figure 10. Network Reduction window: Ward Equivalent. 

 

Once the network is reduced, AC voltage sources and Common Impedances appear in the 
PowerFactory network data. The magnitude, angle, initial active and reactive powers of the 
equivalent network AC voltage sources, as well as network impedances between equivalent AC 
voltage sources in the EMT model were set based on the power-flow solution of the reduced 
PowerFactory case.  
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Figure 11: Network equivalent for Summer Peak network condition in EMT_14.pscx. 

The common impedances between buses could be between different voltages. 

Depending on the network conditions (dispatch, load conditions, reactive power compensation) the 
equivalent network impedance can change.  

4.2 Network Model 

The network model consists of lower South Island generation, including hydro generation at 
Manapouri, Clyde and Roxburgh, as well as wind farms at Kaiwera Downs, Whitehill and 
Mahinerangi. 

 

Figure 12: Region represented in detail in EMT in the network model. 
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4.3 Generation within the Region 

Name of the 
Generator 

Capacity (MVA) Dispatch (MW) Energy Source Model 

Manapouri (MAN) 

135.0 

135.0 

135.0 

135.0 

135.0 

135.0 

135.0 

100.0 

100.0 

100.0 

100.0 

100.0 

100.0 

100.0 

Hydro GENSAE 

 

Roxburgh (ROX) 

 

44.4 

44.4 

44.4 

44.4 

44.4 

44.4 

44.4 

44.4 

42.0 

40.0 

40.0 

40.0 

40.0 

40.0 

8.5 

OOS7 

Hydro GENSAL 

Clyde (CYD) 

120.0 

120.0 

120.0 

120.0 

108.0 

108.0 

108.0 

54.0 

Hydro GENSAE 

Waipori 1 & 2 (WPI) 

12.9 

23.0 

26.1 

26.1 

8.0 

9.0 

6.4 

18.0 

18.0 

12.4 

OOS 

OOS 

Hydro GENSAE 

Roaring Meg (UMG 

and LMG) 

2.5 

1.0 

0.5 

0.9 

1.5 

0.8 

0.4 

0.7 

Hydro GENSAE 

White Hill wind farm 

(WHL) 
66.4 16.5 Wind Type 2 

Kaiwera Downs 

Stage 1 (KWD) 
51 12.9 Wind Type 4 

 

7 OOS-Out of service 



TRANSPOWER NEW ZEALAND   |   GRID ZONE 14 EMT MODEL USER GUIDE 12 

Mahinerangi Wind 

farm (MAH) 
37 10.8 Wind Type 2 

 

 

4.4 Generator Models 

Due to the sensitivity of the information regarding models of generators, generic models have been 
used to model the generators. Synchronous machines are modelled using GENSAE and GENSAL 
models, with their automatic voltage regulators using respective IEEE generic models. Wind farms 
are modelled with generic wind farm models available in PSCAD knowledge base. Table 2 provides 
reference URLs for each resource. 

Table 2. Resource links for wind farm models. 

Wind Farm Type URL 

Type 2 Type 2 Wind Turbine Generators | PSCAD 

Type 4 Type 4 Wind Turbine Generators | PSCAD 

 

4.5 Load Model 

The active and reactive power components of the loads at grid exit points (GXPs) are modelled as 
constant current sources and constant impedance models respectively to align with the widely 
accepted load dynamic characteristics8. 

 

 

Figure 13: Example load representation. 

  

 

8 Kundur, Prabha S., and Om P. Malik. 2022. Power System Stability and Control. 2nd ed. New York: McGraw 
Hill. 

Constant Current – Active 
Power Component

Constant Impedance – 
Reactive Power Component

https://www.pscad.com/knowledge-base/article/225
https://www.pscad.com/knowledge-base/article/227
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5. Update Initial Conditions using Power-flow Data 

 

The update_syncmachines.py and update_loads.py scripts can be used along with 
synchronous_machines.csv and loads.csv to rapidly update the initial conditions of the synchronous 
machines and load values based on the power-flow solution.  

 

5.1 Update Synchronous Machines 

Step 1 

First, the synchronous_machines.csv needs to be updated based on the power-flow solution. Figure 
14 gives an overview of the .csv file data format opened in Excel.   

Note: the user must not change the data order or format.  

 

 

Figure 14: Data format of the synchronous_machines.csv file. 

 

The same generator name used in the EMI case is used in the first column. Columns B and C can be 
left null or populated. Columns D to H need to be updated based on the PowerFactory power-flow 
solution. Once the .csv file is updated, save it in the same folder where the PSCAD case is saved. 

 

Step 2 

Add update_syncmachines.py as a resource to the PSCAD case. Figure 15 gives a snapshot of adding 
the python file to EMT_14.pscx 
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Figure 15: Addition of update_syncmachines.py script. 

 

Step 3 

Double-click the added update_syncmachines.py file. This will open a scripts pane in the PSCAD 
environment. 

 

Figure 16: Scripts pane with the loaded script. 

 

Step 4 

Update the project_name variable with the current PSCAD case that needs to be edited.  

Update the sync_machine_data variable with the absolute file location of the 
synchronous_machines.csv file. 
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Figure 17: Update the project name and sync_machine_data variables. 

 

Step 5 

Press the Run button available in the Scripts pane. This should update the synchronous machines 
within the PSCAD case with the data provided in the synchronous_machines.csv file. The Script 
Output will be populated with generators that are being updated.  

 

5.2 Update Loads 

Step 1 

Update the loads.csv based on the power-flow solution. Figure 18 gives an overview of the .csv file 
data format opened in Excel.  

Note: The user must not change the data order or format.  

 

Figure 18: Data format of the loads.csv file. 



TRANSPOWER NEW ZEALAND   |   GRID ZONE 14 EMT MODEL USER GUIDE 16 

The same load name used in the EMI case is used in the first column. Column B can be left null or 
populated. Columns C to F need to be updated based on the PowerFactory power-flow solution. 
Once the .csv file is updated, save it in the same folder where the PSCAD case is saved. 

 

Step 2 

Add update_loads.py as a resource to the PSCAD case like in section 5.1.  

 

Step 3 

Double-click the added update_loads.py file. This will open a scripts pane in the PSCAD environment. 

 

Figure 19: Scripts pane with the loaded script. 

 

Step 4 

Update the project_name variable with the current PSCAD case that needs to be edited.  

Update the load_data variable with the absolute file location of the loads.csv file. 

 

Figure 20: Update the project name and load_data variables. 
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Step 5 

Press the Run button available in Scripts pane. This should update the synchronous machines within 
the PSCAD case with the data provided in loads.csv file. The Script Output will be populated with 
loads that are being updated.  
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6. Assumptions and Limitations of the Model 

The GZ14_EMT_model.pscx PSCAD network model is provided with the following assumptions and 
limitations: 

• It contains the Grid Zone 14 transmission network modelled in detail, including all the associated 
voltage control system models for generators. The rest of the South Island network is modelled 
as equivalent networks with equivalent generators modelled as a constant frequency AC voltage 
source. This PSCAD network model is suitable for fault ride through and other voltage-related 
system studies.  

• The simulation model requires an Intel® Fortran Compiler Classic 2021.12.0 to compile the 
simulation case.    

• The simulation case was built using PSCAD version 5.0.2.0. 

• The simulation case was developed with Visual Studio 2022. 

• The EMT model has been created for a specific operating point of the power system (2024 
Summer loading in EMI case). Users can modify the system for different study scenarios using 
the python scripts provided.  

• The dynamics of machines are released at 3.0 s of the simulation run. Thus, it is recommended 
to run the simulation further about 3-5 s to ensure the system is in steady state. Verify the system 
is in steady state prior to conducting the studies. 

• The EMT model was converted from the power-flow file using a 20 µs simulation time step. Users 
could reduce the time step further if required, but increasing the simulation time step would 
likely result in errors when performing simulation.  

• The simulation model used simplifies generic models for wind farms due to the restrictions of 
using detailed models. The response of the generic models may not fully represent the behaviour 
of the actual asset(s). 

• The python scripts provided with the model only update the initial condition of generators and 
load values. The transformer tap positions, equivalent network initial conditions and equivalent 
network impedances, wind farm power outputs, filter configurations, and static capacitors and 
inductors within the system are NOT updated automatically. It is highly recommended that users 
verify all parameters and dispatch against the PowerFactory case.  

• The generator internal angles of Lower and Upper Roaring Meg (LMG and UMG) are different to 
that of the PowerFactory power-flow solution. The Cromwell GXP transformer phase shifts 
cannot be correctly modelled in PSCAD transformers. This requires the generator internal angle 
to be advanced +90° (E.g. if PowerFactory angle is  -100°, use -10° in PSCAD). 

• The model is provided with three network equivalents for three different grid configurations. The 
provided EMT_14.pscx is configured for summer peak load condition and if the network 
equivalent is swapped, grid zone 14 must be appropriately updated: synchronous generators, 
loads, reactive power compensation devices, transformer taps.    
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